Since the default version of ImageMagick installed by yum on CentOS 5.5 is  6.2.something, and you want to be able to do all the cool stuff that ImageMagick 6.5.* and 6.6.* can do, you’re gonna have to compile it from source yourself. Don’t worry – it’s easy, and it works.

How to Get ImageMagick 6.5.x or 6.6.x Working on CentOS ...